您的位置:首页 > 其它

POJ 3268 Silver Cow Party (最短路,置换矩阵)

2018-01-11 21:37 369 查看
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤
X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road
i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:
N, M, and X

Lines 2.. M+1: Line i+1 describes road i with three space-separated integers:
Ai, Bi, and Ti. The described road runs from farm
Ai to farm Bi, requiring Ti time units to traverse.

Output
Line 1: One integer: the maximum of time any one cow must walk.

Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output
10

Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:n个点,m条单向边,每个点的牛都要到一个点k去并回来,要求来回路程的最大值。

刚开始看到这题,首先求出k点到每个点的最短距离,然后遍历每一个点到k点的距离,求出两段值的和的最大值。但这样显然会超时的。然后看到别人的博客说将矩阵置换一下就好了,原因可以这样理解:要求每个点到k点的最短距离,将路径反过来再求k点到每个点的最短距离,那么就变成了每个点到k点的最短距离了。

超时代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define N 1000
#define inf 0x3fffffff
int m,n,k,dis1[N+1],dis[N+1],e[N+1][N+1];
bool vis[N+1];
void dijkstra(int x)
{
memset(vis,false,sizeof(vis));
for(int i=0;i<n;i++)
dis[i]=e[x][i];
for(int i=0;i<n-1;i++)
{
int tmp=inf,u=-1;
for(int j=0;j<n;j++)
{
if(tmp>dis[j]&&!vis[j]&&dis[j])
{
tmp=dis[j];
u=j;
}
}
if(u==-1) break;
vis[u]=true;
for(int j=0;j<n;j++)
{
if(j==x) continue;
if(!vis[j]&&e[u][j]&&(dis[j]>dis[u]+e[u][j]||!dis[j]))
dis[j]=dis[u]+e[u][j];
}
}
}
int main()
{
int a,b,c,ans=0;
scanf("%d%d%d",&n,&m,&k);
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&a,&b,&c);
e[a-1][b-1]=c;
}
for(int i=0;i<n;i++)
dis1[i]=e[k-1][i];
for(int i=0;i<n-1;i++)
{
int t=inf,uu=-1;
for(int j=0;j<n;j++)
{
if(t>dis1[j]&&!vis[j]&&dis1[j])
{
t=dis1[j];
uu=j;
}
}
if(uu==-1) break;
vis[uu]=true;
for(int j=0;j<n;j++)
{
if(j==k-1) continue;
if(!vis[j]&&e[uu][j]&&(dis1[j]>dis1[uu]+e[uu][j]||!dis1[j]))
dis1[j]=dis1[uu]+e[uu][j];
}
}
// for(int i=0;i<n;i++)
// printf("%d ",dis1[i]);
for(int i=0;i<n;i++)
{
if(i==k-1) continue;
dijkstra(i);
ans=max(ans,dis[k-1]+dis1[i]);
}
printf("%d\n",ans);
}正解:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define N 1000
#define inf 0x3fffffff
int m,n,k,dis1[N+1],dis[N+1],e[N+1][N+1];
bool vis[N+1];
void dijkstra(int x)
{
memset(vis,false,sizeof(vis));
for(int i=0;i<n;i++)
dis[i]=e[x][i];
for(int i=0;i<n-1;i++)
{
int tmp=inf,u=-1;
for(int j=0;j<n;j++)
{
if(tmp>dis[j]&&!vis[j]&&dis[j])
{
tmp=dis[j];
u=j;
}
}
if(u==-1) break;
vis[u]=true;
for(int j=0;j<n;j++)
{
if(j==x) continue;
if(!vis[j]&&e[u][j]&&(dis[j]>dis[u]+e[u][j]||!dis[j]))
dis[j]=dis[u]+e[u][j];
}
}
}
int main()
{
int a,b,c,ans=0;
scanf("%d%d%d",&n,&m,&k);
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&a,&b,&c);
e[a-1][b-1]=c;
}
dijkstra(k-1);
for(int i=0;i<n;i++)
dis1[i]=dis[i];
for(int i=0;i<n;i++)
for(int j=i+1;j<n;j++)
swap(e[i][j],e[j][i]);
dijkstra(k-1);
for(int i=0;i<n;i++)
ans=max(ans,dis1[i]+dis[i]);
printf("%d\n",ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  最短路 poj