您的位置:首页 > 其它

《算法艺术与信息学竞赛》之 排序与检索 排序 uva120

2017-12-16 17:35 295 查看
Stacks and Queues are often considered the bread and butter of data structures and find use in architecture,

parsing, operating systems, and discrete event simulation. Stacks are also important in the

theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in

addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted

so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a

pancake is given by the pancake’s diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake “flips”. A flip consists of inserting a spatula

between two pancakes in a stack and flipping (reversing) all the pancakes on the spatula (reversing the

sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to

be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1

and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the

pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most

pancake of the left stack):

8 7 2

4 6 5

6 4 8

7 8 4

5 5 6

2 2 7

The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can

be transformed into the right stack via the command flip(1).

Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30

pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated

by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing

first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some

sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake

is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by

a ‘0’ (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5

5 4 3 2 1

5 1 2 3 4

Sample Output

1 2 3 4 5

0

5 4 3 2 1

1 0

5 1 2 3 4

1 2 0

题目中给出了一些煎饼(这里吐槽一下,不知道为什么这家煎饼是叠着煎的)要求按照半径将其排序好,每次可以一铲子下去将这个煎饼和它上面的全部倒过来。

我认为这个算法其实是基于贪心的,每次将最大的煎饼放在最下面即可,那么我们如何操作呢?

其实非常简单,首先我们进行一次操作将其放置顶端,接下来再进行一次操作将其放置它应在的位置上即可,很容易看出这是不会影响到下面已经有序的煎饼的。

细节上大家要注意一下输入的处理,另外,输入数据是把煎饼从高往底排的,即底部的煎饼排在最后。

#include<bits/stdc++.h>
using namespace std;
int a[102],b[102],num,p,tot,now;
void re(int x){
int i,j;
for(i=0,j=x;j>i;j--,i++)
swap(a[i],a[j]);
}
int main(){
while(scanf("%d",&a[0])==1){
num=1;
while(1){
if(getchar()!=' ')
break;
scanf("%d",&a[num]);
num++;
}
printf("%d",a[0]);
for(int i=1; i<num; i++)
printf(" %d",a[i]);
printf("\n");
tot=0;
for(int i=0;i<num;i++){
now=0;
for(int j=num-i-1;j>=0;j--)
if(now<a[j]){
now=a[j];
p=j;
}
if(p!=num-i-1){
if(p!=0){
re(p);
b[tot++]=num-p;
}
re(num-i-1);
b[tot++]=i+1;
}
}
if(!tot)
printf("%d\n",0);
else{
for(int i=0;i<tot;i++)
printf("%d ",b[i]);
printf("%d\n",0);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva 算法