您的位置:首页 > 其它

uva 120 Stacks of Flapjacks(检索)

2013-07-26 21:00 387 查看


 Stacks of Flapjacks 


Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.


The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a
stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of
the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):
8           7           2
4           6           5
6           4           8
7           8           4
5           5           6
2           2           7

The stack on the left can be transformed to the stack in the middle via flip(3).
The middle stack can be transformed into the right stack via the command flip(1).


The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input
with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.


The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each
stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.


Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4



Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

题目大意:一摞盘子,从上到下。个数1=<N<=30,盘子直径D,1~100,求:每次只能执行从顶部到某一个的反转,也就是像堆栈一样,先倒出来,再倒回去,最终实现,从顶到底有序(升序)。输出每次反转的位置(即每次反转的底层位置),编号从底到顶从1~N。(没要求最优,能够实现就可以)。
解题思路:模拟。

复杂度o(n^2);

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define N 105

void change(int num[], int n){
int t;
for (int i = 1; i <= n / 2; i++){
t = num[i];
num[i] = num[n - i + 1];
num[n - i + 1] = t;
}
}

int main(){
int n;
char c;
int num
;
int tem
;

while (1){

// Init.
memset(num, 0, sizeof(num));
memset(tem, 0, sizeof(tem));
n = 0;

// Read.
while (1){
if (scanf("%d%c", &num[++n], &c) != 2)
goto out;
tem
= num
;
if (c == '\n')
break;
}

// Ready.
sort(tem, tem + n + 1);

// Printf.
for (int i = 1; i < n; i++)
printf("%d ", num[i]);
printf("%d\n", num
);

// Count.
for (int i = n; i >= 0; i--){
if (num[i] == tem[i])
continue;
for (int j = i - 1; j > 0; j--){
if (num[j] == tem[i]){
if (j != 1){
printf("%d ", n + 1 - j);
change(num, j);
}
printf("%d ", n - i + 1);
change(num, i);
break;
}
}
}
printf("0\n");
}
out:
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: