您的位置:首页 > 其它

HDOJ1326 Box of Bricks

2017-12-07 12:34 363 查看

Box of Bricks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8281    Accepted Submission(s): 3591


[align=left]Problem Description[/align]
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same
height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to
do this with the minimum number of bricks moved. Can you help?



 

[align=left]Input[/align]
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

 

[align=left]Output[/align]
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks
the same height.

Output a blank line after each set.

 

[align=left]Sample Input[/align]

6
5 2 4 1 7 5
0

 

[align=left]Sample Output[/align]

Set #1
The minimum number of moves is 5.

 计算平均值,只算大于平均值的或者只算小于平均值的数,
例如只算小于平均值的数,用平均值减掉该数加到sum,全部加起来就是答案。
import java.util.Scanner;

public class Main{
private static Scanner scanner;
public static void main(String[] args) {
scanner = new Scanner(System.in);
int cases = 1;
while(scanner.hasNext()){
int n = scanner.nextInt();
if(n==0){
break;
}
int arr[] = new int
;
int aver = 0;
for (int i = 0; i < arr.length; i++) {
arr[i] = scanner.nextInt();
aver+=arr[i];
}
aver /= arr.length;
int count = 0;
for (int i = 0; i < arr.length; i++) {
if(arr[i]<aver){
count  = count+aver-arr[i];
}
}
System.out.println("Set #"+cases++);
System.out.println("The minimum number of moves is "+count+".");
System.out.println();
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: