您的位置:首页 > 其它

HDU 1326 Box of Bricks

2016-08-04 16:34 381 查看

Box of Bricks

[align=left]Problem Description[/align]
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same
height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to
do this with the minimum number of bricks moved. Can you help?



 

[align=left]Input[/align]
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

 

[align=left]Output[/align]
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks
the same height.

Output a blank line after each set.

 

[align=left]Sample Input[/align]

6
5 2 4 1 7 5
0

 

[align=left]Sample Output[/align]

Set #1
The minimum number of moves is 5.

题意:给出初始的一排砖块摞,求出要想让他们等高需要移动至少多少个砖块。

首先这里所有的砖块不一定是摞数的整数倍,所以求出整型平均值,把剩下的多余砖块先加入到最后需要移动总数中,因为那些确定是要必须移开的。最后找出比平均值少的摞还需要多少砖块才能填平,就是最后填补需要移动的总数。

#include<stdio.h>
#include<string.h>
int main()
{
int t,n,i,j,sum;
int e=0,a[100];
while(~scanf("%d",&t)&&t)
{
e++;
printf("Set #%d\n",e);
sum=0;
for(i=0;i<t;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
int ev=sum/t;
sum=sum-ev*t;
for(i=0;i<t;i++)
{
if(a[i]<ev)
sum+=ev-a[i];
}
printf("The minimum number of moves is %d.\n",sum);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM HDU