您的位置:首页 > 其它

hdu1016 Prime Ring Problem()

2017-12-07 11:57 281 查看
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 


 

Inputn (0 < n < 20). 

OutputThe output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical
order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input
6
8


Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn=100;
int prime[maxn];
int ans[maxn];
int n;
void ini()
{
int m=sqrt(maxn+0.5);
memset(prime,0,sizeof(prime));
for(int i=2;i<=m;i++)
if(!prime[i])
for(int j=i*i;j<=maxn;j+=i)
prime[j]=1;
}
void dfs(int cur)
{
if(cur>n){
cout<<ans[1];
for(int i=2;i<=n;i++)cout<<" "<<ans[i];
cout<<endl;
}
if(cur==1){
ans[cur]=1;
dfs(cur+1);
}
else
for(int i=1;i<=n;i++){
int flag=1;
for(int j=1;j<cur;j++){
if(ans[j]==i){
flag=0;
break;
}
}
if(cur!=n)
if(prime[i+ans[cur-1]]==0&&flag){
ans[cur]=i;
dfs(cur+1);
}
if(cur==n){
if(prime[i+ans[cur-1]]==0&&prime[i+ans[1]]==0&&flag){
ans[cur]=i;
dfs(cur+1);
}
}
}
}
int main()
{
int ncase=1;
ini();
while(cin>>n){
cout<<"Case "<<ncase++<<":"<<endl;
dfs(1);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs