您的位置:首页 > 其它

HDU - 1016 Prime Ring Problem(dfs,素数环)

2017-11-30 20:58 309 查看


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55512    Accepted Submission(s): 24583


Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

6
8

 

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

Source

Asia 1996, Shanghai (Mainland China)

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1010 1241 1312 1072 1242 

题意:用1~n的n个数构成一个环,要求相邻两数相加为素数

直接dfs一发,用deque储存一下结果即可

#include <bits/stdc++.h>
using namespace std;

int n, p = 0;
int v[30];
int vis[50];

void xx(){
for(int i = 1; i <= 40; i++){
int flag = 0;
for(int j = 2; j < i; j++){
if(i%j == 0) flag = 1;
}
if(!flag) vis[i] = 1;
}
}

deque<int> k;
void Dfs(int pos, int val){
if(pos == n){
if(!vis[val+1]) return;
printf("1");
int l = k.size(), x;
for(int i = 0; i < l; i++){
x = k.front();
printf(" %d", x);
k.pop_front();
k.push_back(x);
}
printf("\n");
return;
}
for(int i = 2; i <= n; i++){
if(v[i]) continue;
if(vis[i+val]){
v[i] = 1;
k.push_back(i);
Dfs(pos+1, i);
v[i] = 0;
if(!k.empty()) k.pop_back();
}
}
}

int main(){
xx();
while(scanf("%d", &n) == 1){
printf("Case %d:\n", ++p);
Dfs(1, 1);
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: