您的位置:首页 > 其它

poj - 1284 - Primitive Roots - (欧拉函数求原根)

2017-11-15 12:52 302 查看
We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2,
6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 

Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input
Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output
For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input
23
31
79


Sample Output
10
8
24


题目让求一个奇素数的原根的个数

有定理:如果p为素数,那么素数p一定存在原根,又因为当模p有原根时,它有φ(φ(p))个原根,那么对于素数p的原根的个数为φ(p−1)。

具体定义见百科:原根http://blog.csdn.net/muxidreamtohit/article/details/8026611

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
#define M 65540

int phi[M];
void init() //预先求出所有的欧拉函数
{
int i,j;
for(i=2;i<M;i++)
phi[i]=0;
phi[1]=1;
for(i=2;i<M;i++)
if(!phi[i])
{
for(j=i;j<M;j+=i)
{
if(!phi[j])
phi[j]=j;
phi[j]=phi[j]/i*(i-1);
}
}
}

int main()
{
init();
int n;
while(scanf("%d",&n)!=EOF)
{
printf("%d\n",phi[n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: