您的位置:首页 > 其它

HDU1358 Period(KMP,找循环节)

2017-09-14 20:48 375 查看

Problem Description

For each prefix of a given string S with N characters (each character

has an ASCII code between 97 and 126, inclusive), we want to know

whether the prefix is a periodic string. That is, for each i (2 <= i

<= N) we want to know the largest K > 1 (if there is one) such that

the prefix of S with length i can be written as AK , that is A

concatenated K times, for some string A. Of course, we also want to

know the period K.

Input

The input file consists of several test cases. Each test case consists

of two lines. The first one contains N (2 <= N <= 1 000 000) – the

size of the string S. The second line contains the string S. The input

file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case

number on a single line; then, for each prefix with length i that has

a period K > 1, output the prefix size i and the period K separated by

a single space; the prefix sizes must be in increasing order. Print a

blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0


Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


思路

给了一个长度为n的字符串,然后让你找每一个前缀(从第二个字母开始)是否是循环的,如果是就把当前的位置和循环节的长度输出

实际上就是 next 数组的使用,令j<
4000
/span>=i−next[i],如果i%j==0就证明存在循环节,循环节的长度为i/j

代码

#include<cstdio>
#include<cstring>
#include<string>
#include<set>
#include<iostream>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define mod 10000007
#define debug() puts("what the fuck!!!")
#define N 1000000+20
#define ll longlong
using namespace std;
char s
;
int nxt
;
void get_next(int len)
{
int j=0,k=-1;
nxt[0]=-1;
while(j<len)
if(k==-1||s[j]==s[k])
nxt[++j]=++k;
else
k=nxt[k];
}
int main()
{
int n,q=1;
while(~scanf("%d",&n)&&n)
{
scanf("%s",s);
printf("Test case #%d\n",q++);
get_next(n);
for(int i=1; i<=n; i++)
{
int j=i-nxt[i];
if(i%j==0&&i/j>1)
printf("%d %d\n",i,i/j);
}
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: