您的位置:首页 > 其它

[POJ](3070)Fibonacci ---矩阵快速幂与斐波那契

2017-09-12 16:34 337 查看
Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16291 Accepted: 11438
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

Source

Stanford Local 2006

熟悉矩阵快速幂~

AC代码:
#include<iostream>
#include<cstring>
#include<cstdio>
const int MOD = 10000;
using namespace std;
typedef struct node
{
long long a[2][2];
}matrix;
matrix matMul(matrix x,matrix y) //矩阵乘法
{
matrix res;
memset(res.a,0,sizeof(res.a));
for(int i=0;i<2;i++)
{
for(int j=0;j<2;j++)
{
for(int k=0;k<2;k++)
{
res.a[i][j]+=x.a[i][k]*y.a[k][j];
res.a[i][j]%=MOD;
}
}
}
return res;
}
long long pow(int p)  //矩阵快速幂
{
matrix res;
matrix c;
memset(c.a,0,sizeof(c.a));
memset(res.a,0,sizeof(res.a));
for(int i=0;i<2;i++)
res.a[i][i] = 1;
c.a[0][0]=1,c.a[0][1]=1;
c.a[1][0]=1,c.a[1][1]=0;
while(p)
{
if(1&p) res = matMul(res,c);
c = matMul(c,c);
p>>=1;
}
return res.a[0][1];
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
if(n == -1)
break;
printf("%lld\n",pow(n)%MOD);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: