您的位置:首页 > 其它

poj 3070 Fibonacci(矩阵快速幂模板,斐波那契)

2016-07-18 17:35 369 查看
Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12812 Accepted: 9109
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

题意:求f
,f为斐波那契数列

思路:矩阵快速幂和一般的快速幂是一样的,只是把普通的乘法改成矩阵乘法即可,可以当模板。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define mod 10000
struct Matrix
{
long long ma[2][2];
};
Matrix mul(Matrix A,Matrix B)
{
Matrix C;
C.ma[0][0]=C.ma[0][1]=C.ma[1][0]=C.ma[1][1]=0;
for(int i=0;i<2;i++)
{
for(int j=0;j<2;j++)
{
for(int k=0;k<2;k++)
{
C.ma[i][j]=(C.ma[i][j]+A.ma[i][k]*B.ma[k][j])%mod;
}
}
}
return C;
}
Matrix pow_mod(Matrix A,long long n)
{
Matrix B;
B.ma[0][0]=B.ma[1][1]=1;
B.ma[0][1]=B.ma[1][0]=0;
while(n)
{
if(n&1) B=mul(B,A);
A=mul(A,A);
n>>=1;
}
return B;
}
int main()
{
long long n;
while(~scanf("%lld",&n)&&n!=-1)
{
Matrix A;
A.ma[0][0]=1;A.ma[0][1]=1;
A.ma[1][0]=1;A.ma[1][1]=0;
Matrix ans=pow_mod(A,n);
printf("%lld\n",ans.ma[0][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: