您的位置:首页 > 产品设计 > UI/UE

4 Values whose Sum is 0 (POJ-2785) (折半枚举)

2017-08-29 15:36 411 查看
题目链接:http://poj.org/problem?id=2785

4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 23959 Accepted: 7263
Case Time Limit: 5000MS
Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output
5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题目大意:

给出四个集合,每个集合取一个数加起来为 0 。   例如a+b+c+d=0

题目分析:

由于直接暴力搜索是n*n*n*n种会超时,但是分成两半的的话枚举则不会。

可以先把c和d的和枚举出来,再进行排序。

代码用到了STL的两个二分查找函数

 lower_bound
算法返回一个非递减序列[first, last)中的第一个大于等于值val的位置。

 upper_bound
算法返回一个非递减序列[first, last)中第一个大于val的位置。

如图所示:



代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <map>
#include <set>
#include <vector>
using namespace std;
typedef long long LL;
const int N=4444+999;
int n,m;
int a
,b
,c
,d
;
int cd[N*N];
int main()
{
while(scanf("%d",&n)!=EOF)
{
for(int i=0; i<n; i++)
scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
for(int i=0;i<n;i++) //枚举cd
for(int j=0;j<n;j++)
cd[i*n+j]=c[i]+d[j];
sort(cd,cd+n*n);
LL res=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
int ab=a[i]+b[j];//枚举ab
res+= upper_bound(cd,cd+n*n,-ab) - lower_bound(cd,cd+n*n,-ab);//查找a+b+c+d=0的数量
}
}
printf("%lld\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: