您的位置:首页 > 产品设计 > UI/UE

POJ 2785 4 VALUES WHOSE SUM IS 0 【折半枚举】

2015-06-05 23:41 567 查看
Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6

-45 22 42 -16

-41 -27 56 30

-36 53 -37 77

-36 30 -75 -46

26 -38 -10 62

-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

折半枚举时间复杂度O(n^2logn)

代码:

[code]#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <iostream>
#include <set>
#include <string.h>
#include <functional>

using namespace std;

int a[4444],b[4444],c[4444],d[4444];
int p [4444 * 4444];

int main()
{
    int n ;
    while (scanf("%d",&n)!=EOF)
    {
        for (int i=0;i<n;i++)
            scanf ("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);

        for (int i=0;i<n;i++)
            for (int j=0;j<n;j++)
        {
            p[i*n+j] = a[i] + b[j] ;
        }

        sort (p,p+n*n);
        long long  ans = 0;
        for (int i=0;i<n;i++)
            for (int j=0;j<n;j++)
        {
            int cd = -1*(c[i] + d[j]);
            ans += (upper_bound(p,p+n*n ,cd) - lower_bound(p,p+n*n,cd));
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: