您的位置:首页 > 产品设计 > UI/UE

【POJ 2785 4 Values whose Sum is 0】+ 折半枚举(双项搜索))

2016-11-23 21:28 525 查看
4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K

Total Submissions: 20492 Accepted: 6148

Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6

-45 22 42 -16

-41 -27 56 30

-36 53 -37 77

-36 30 -75 -46

26 -38 -10 62

-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意 :从四个数组里各抽取一个数和为零

思路 : 直接暴力n ^ 4肯定超时~加点小技巧~折半枚举~预处理其中两个数组的和~枚举另外两个数组的和~二分查找处理好的数组~

AC代码 :

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN = 4010;
int A[MAXN],B[MAXN],C[MAXN],D[MAXN],CD[MAXN * MAXN],N;
void solve(){ // 折半查找
for(int i = 0 ; i < N ; i++)
for(int j = 0 ; j < N; j++)
CD[i * N + j] = C[i] + D[j];
sort(CD,CD + N * N);
long long ans = 0;
for(int i = 0 ; i < N ; i++)
for(int j = 0 ; j < N; j++){
int cut = -(A[i] + B[j]);
ans += upper_bound(CD,CD + N * N,cut) - lower_bound(CD,CD + N * N,cut);
}
printf("%lld\n",ans);
}
int main()
{
while(scanf("%d",&N) != EOF){
for(int i = 0 ; i < N ; i++)
scanf("%d %d %d %d",&A[i],&B[i],&C[i],&D[i]);
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj