您的位置:首页 > 其它

PAT甲级1005. Spell It Right (20)

2017-08-28 22:31 459 查看

题目链接

https://www.patest.cn/contests/pat-a-practise/1005

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345

Sample Output:
one five

思路分析

由于给定的数字较长,用字符数组存储,然后计算出和,再把和按每一位存储到字符数组,再遍历

注意 输入为0 时 输出 zero

代码

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
char a[101];
char b[101];
gets(a);
//puts(a);
int sum = 0;
int i = 0;
while(i!=strlen(a))
{
sum =sum + (a[i]-'0');
i++;
}
int j = 0;
if(sum == 0)
cout<<"zero";
else
{
while(sum)
{
b[j] = sum%10+'0';
sum/=10;
j++;
}
for(int k = j-1;k >= 0;k--)
{
if(b[k] == '0') cout<<"zero";
if(b[k] == '1') cout<<"one";
if(b[k] == '2') cout<<"two";
if(b[k] == '3') cout<<"three";
if(b[k] == '4') cout<<"four";
if(b[k] == '5') cout<<"five";
if(b[k] == '6') cout<<"six";
if(b[k] == '7') cout<<"seven";
if(b[k] == '8') cout<<"eight";
if(b[k] == '9') cout<<"nine";
if(k!=0) cout<<" ";
}
}
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: