您的位置:首页 > 其它

PAT甲级.1005. Spell It Right (20)

2018-04-10 15:43 591 查看

1005. Spell It Right (20)

题目

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

输入格式

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

输出格式

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

输入样例

12345

输出样例

one five

PAT链接

思路:

1.二维数组存单词:

char convert[10][6] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};


2.统计各位数字之和,从个位开始入栈

// 统计字串各位数数字和
for(int i = 0; i < len; i++)
{
sum += str[i] - '0';
}
// 每一位入栈再pop出来
do
{
st.push(sum % 10);
cnt++;
sum /= 10;
} while (sum != 0);


代码:

/**
* @tag     PAT_A_1005
* @authors R11happy (xushuai100@126.com)
* @date    2016-8-28 00:08-00:24
* @version 1.0
* @Language C++
* @Ranking  340/2590
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <stack>
using namespace std;

char convert[10][6] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};

int main(int argc, char const *argv[])
{
stack<int> st;
char str[110];
gets(str);
int len = strlen(str);
int sum = 0;
int cnt = 0;    //记录入栈个数
// 统计字串各位数数字和
for(int i = 0; i < len; i++)
{
sum += str[i] - '0';
}
// 每一位入栈再pop出来
do
{
st.push(sum % 10);
cnt++;
sum /= 10;
} while (sum != 0);
for(int i = 0; i<cnt-1; i++)
{
printf("%s ",convert[st.top()] );
st.pop();
}
printf("%s",convert[st.top()] );
st.pop();
return 0;
}


收获:

熟悉栈(stack)的使用

1.声明

#include <stack>
using namespace std;


2.定义

char str[110];


3.push

4.top, pop
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  字符串处理