您的位置:首页 > 其它

PAT (Advanced Level) 1005. Spell It Right (20)

2017-03-09 00:09 417 查看


1005. Spell It Right (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345

Sample Output:
one five


这道题刚开始没有仔细看,以为很简单,后来发现有两个测试点过不去,,才发现,原来位数digit是10的100次方级别(最大的)所以,如果按照原始的判断不超过三位是错误的。。。

这里我还是用了stack来倒一下结果。。。然后用了vector,没有用string,string应该也可以,,但是还是不熟悉~

刚开始还把除和取余数搞混了,,然后就是size()要减1,最后stack()输出注意一下就ok了~

#include<cstdio>
#include<string.h>
#include<vector>
#include<string>
#include<stack>
#include<algorithm>

using namespace std;
const int maxn = 1000000000;

char s[10][10] = { "zero","one","two","three","four","five","six","seven","eight","nine" };
//char a[maxn];
vector<char> a;
stack<int> rr;

int main() {
long long ans = 0;
char temp;
while (scanf("%c", &temp) && temp!= '\n') {
a.push_back(temp);
}
a.push_back('\0');

for (int i = 0; i < a.size()-1; i++) {
//printf("size: %d\n", a.size());
ans += a[i] - '0';
}

while (ans / 10 != 0) {
rr.push(ans % 10);
//printf("%s ", s[ans % 10]);
ans /= 10;
}
rr.push(ans);

while(!rr.empty()) {
int r;
r = rr.top();
rr.pop();
printf("%s", s[r]);
if (!rr.empty()) {
printf(" ");
}
else {
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: