您的位置:首页 > 其它

PAT 1012. The Best Rank (25) 未通过,段错误

2017-08-23 19:52 369 查看
o evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing
on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91


Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student
ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".
Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output
1 C
1 M
1 E
1 A
3 A
N/A

#include<iostream>
#include<stdio.h>
#include<iomanip>
#include<string>
#include<algorithm>

using namespace std;

int n,m;
string tmp;
int p=0;

struct CMP
{
int value;
string
4000
id;
bool operator < (const CMP &A) const{

return value>=A.value;

}
int mc;
}cmpp[2111];

struct ZZ{
string id;
int cs,ms,es,as,cr,mr,er,ar,best;
char letter;

}index[2111];

void judge()
{
for(int i=0;i<n;i++)
{   cmpp[i].id=index[i].id;
cmpp[i].value=index[i].as;
}
sort(cmpp,cmpp+n);
cmpp[0].mc=1;
for(int i=1;i<n;i++)
{   if(cmpp[i].value==cmpp[i-1].value) cmpp[i].mc=cmpp[i-1].mc;
else cmpp[i].mc=i+1;
}

for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(cmpp[i].id==index[j].id) index[j].ar=cmpp[i].mc;

for(int i=0;i<n;i++)
{   cmpp[i].id=index[i].id;
cmpp[i].value=index[i].cs;
}
sort(cmpp,cmpp+n);
cmpp[0].mc=1;
for(int i=1;i<n;i++)
{   if(cmpp[i].value==cmpp[i-1].value) cmpp[i].mc=cmpp[i-1].mc;
else cmpp[i].mc=i+1;
}
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(cmpp[i].id==index[j].id) index[j].cr=cmpp[i].mc;

for(int i=0;i<n;i++)
{   cmpp[i].id=index[i].id;
cmpp[i].value=index[i].es;
}
sort(cmpp,cmpp+n);
cmpp[0].mc=1;
for(int i=1;i<n;i++)
{   if(cmpp[i].value==cmpp[i-1].value) cmpp[i].mc=cmpp[i-1].mc;
else cmpp[i].mc=i+1;
}
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(cmpp[i].id==index[j].id) index[j].er=cmpp[i].mc;

for(int i=0;i<n;i++)
{   cmpp[i].id=index[i].id;
cmpp[i].value=index[i].ms;
}
sort(cmpp,cmpp+n);
cmpp[0].mc=1;
for(int i=1;i<n;i++)
{   if(cmpp[i].value==cmpp[i-1].value) cmpp[i].mc=cmpp[i-1].mc;
else cmpp[i].mc=i+1;
}
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(cmpp[i].id==index[j].id) index[j].mr=cmpp[i].mc;

for(int i=0;i<n;i++)
{
if(index[i].ar<=index[i].cr&&index[i].ar<=index[i].er&&index[i].ar<=index[i].mr)
{ index[i].letter='A';
index[i].best=index[i].ar;

}

else if(index[i].cr<index[i].ar&&index[i].cr<=index[i].er&&index[i].cr<=index[i].mr)
{ index[i].letter='C';
index[i].best=index[i].cr;

}
else if(index[i].mr<index[i].cr&&index[i].mr<index[i].ar&&index[i].mr<=index[i].er)
{ index[i].letter='M';
index[i].best=index[i].mr;

}
else if(index[i].er<index[i].cr&&index[i].er<index[i].ar&&index[i].er<index[i].mr)
{ index[i].letter='E';
index[i].best=index[i].er;

}

}

}

using namespace std;
int main()
{

cin>>n>>m;

for(int i=0;i<n;i++)
{
cin>>tmp;
index[p].id=tmp;
cin>>index[p].cs>>index[p].ms>>index[p].es;
index[p].as=(index[p].cs+index[p].ms+index[p].es)/3;
p++;
}

judge();

for(int i=0;i<m;i++)
{  int flag=0;
cin>>tmp;
for(int j=0;j<n;j++)
{
if(index[j].id==tmp)
{  flag=1;
cout<<index[j].best<<' '<<index[j].letter<<endl;

}

}
if(flag==0) cout<<"N/A"<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: