您的位置:首页 > 运维架构

PAT 1044. Shopping in Mars (25)

2017-08-29 14:00 423 查看


1044. Shopping in Mars (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the
chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).

2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).

3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has
to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds.
All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order
of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again
all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.
Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:
1-5
4-6
7-8
11-11

Sample Input 2:
5 13
2 4 5 7 9

Sample Output 2:
2-4
4-5

各种超时,逼着我改进算法。。然后感觉这个算法时间复杂度o(2n)已经无法在优化了,还是超时。然后发现自己是用的cout。改成printf就过了
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
#include<map>
using namespace std;

struct
{
int head,tail;
}node[100000];
int n,m;
int a[100001];

int main()
{
int p=0;
cin>>n>>m;
int minn=99999;
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}

int i=0,j=0;
int tmp=a[0]-m;
for(i=0;i<n;i++)
{
if(i!=0)tmp-=a[i-1];
if(j==n) break;
tmp-=a[j];
for(;j<n;j++)
{
tmp+=a[j];
if(tmp>=0)
{
if(tmp<minn)
{
minn=tmp;
p=0;
node[p].head=i;
node[p].tail=j;
p++;
}
else if(tmp==minn)
{
node[p].head=i;
node[p].tail=j;
p++;
}
break;
}
}
}
for(int i=0;i<p;i++)
//cout<<node[i].head+1<<'-'<<node[i].tail+1<<endl;
printf("%d-%d\n",node[i].head+1,node[i].tail+1);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: