您的位置:首页 > 其它

PAT 1043. Is It a Binary Search Tree (25) 建树

2017-08-29 11:49 405 查看


1043. Is It a Binary Search Tree (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All
the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11

Sample Output 1:
YES
5 7 6 8 11 10 8

Sample Input 2:
7
8 10 11 8 6 7 5

Sample Output 2:
YES
11 8 10 7 5 6 8

Sample Input 3:
7
8 6 8 5 10 9 11

Sample Output 3:
NO


注意模拟动态申请数组!!!!!!!!千万要小心!!!!
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
#include<map>
using namespace std;
int p=0;
int flg=0;

struct ZZ
{
ZZ *lc,*rc;
int value;
}node[1005];

int a[1001];
int flag;

ZZ* judge1(int p1,int p2)
{
if(flag==1) return NULL;
int p3=p1+1;
while(p3<=p2&&a[p1]>a[p3])
p3++;
for(int i=p3+1;i<=p2;i++)
if(a[i]<a[p1])
{
flag=1;
return NULL;
}

ZZ *tmp=&node[p++];
tmp->value=a[p1];
if(p3==p1+1) tmp->lc=NULL;
else tmp->lc=judge1(p1+1,p3-1);
if(p3>p2) tmp->rc=NULL;
else tmp->rc=judge1(p3,p2);
return tmp;
}

ZZ* judge2(int p1,int p2)
{
if(flag==1) return NULL;
int p3=p1+1;
while(p3<=p2&&a[p1]<=a[p3])
p3++;
for(int i=p3+1;i<=p2;i++)
if(a[i]>=a[p1])
{
flag=1;
return NULL;
}

ZZ *tmp=&node[p++];
tmp->value=a[p1];
if(p3==p1+1) tmp->lc=NULL;
else tmp->lc=judge2(p1+1,p3-1);
if(p3>p2) tmp->rc=NULL;
else tmp->rc=judge2(p3,p2);
return tmp;
}

void bianli(ZZ* oo)
{
if(oo==NULL) return;
bianli(oo->lc);
bianli(oo->rc);
if(flg==1) cout<<' ';
flg=1;
cout<<oo->value;
}

int main()
{
int n;
cin>>n;
for(int i=0;i<n;i++)
cin>>a[i];
p=0;
flag=0;
ZZ *tmpp=judge1(0,n-1);
if(flag==0) {cout<<"YES"<<endl;bianli(tmpp);return 0;}
p=0;flag=0;
tmpp=judge2(0,n-1);
if(flag==0) {cout<<"YES"<<endl;bianli(tmpp);return 0;}
cout<<"NO";

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: