您的位置:首页 > 其它

山东省第八届ACM省赛 I 题 Parity check 详解

2017-08-17 12:04 411 查看

Parity check

Time Limit: 2000MSMemory Limit: 524288KB

Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:

f(n)=


She is required to calculate f(n) mod 2 for each givenn. Can you help her?

Input

Multiple test cases. Each test case is an integern(0≤n≤

) in a single line.

Output

For each test case, output the answer of f(n)mod2.

Example Input

2


Example Output

1


题意:

利用菲波那切数列的递推公式,得到f(n),求f(n)%2 的值。

思路:

这个题,并不需要求出 f(n),由于n 太大,所以刚开始就没想求出f(n) ,就试着去找找规律(因为结果只有0 或者1)。然后,就发现了如下规律

序号
01234567891011
f(n)01123581321345589
结果011011011011
sum = sum % 3 不但不会影响最终结果,反而 会简化取模过程。要是不行,你可以手算模拟下

AC代码:g++  0ms

#include<cstdio>    //AC G++ 0ms
#include<cstring>
using namespace std;
char str[1000+10];    //数组往往 开大点
int main()
{
while(scanf("%s",str)!=EOF) {   //字符串,多组测试案例输入
int len = strlen(str);
int sum=0;
for(int i=0; i<len; i++)
{
sum = sum*10+(str[i]-'0');
sum = sum % 3;  //从规律中发现,每 一个循环节是 3 个数
}
if(sum == 0) printf("0\n");
else if(sum==1 || sum==2) printf("1\n");
}
return 0;
}
sdut 3901
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: