您的位置:首页 > 其它

HDU6106-Classes

2017-08-11 17:24 113 查看

Classes

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 492 Accepted Submission(s): 307

Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.

Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.

Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.

However, due to statistical errors, some data are wrong and these data should be ignored.

Smart you must know how to write a program to find the maximum number of students.

Input

The first line of the input gives the number of test cases T; T test cases follow.

Each case begins with one line with one integer N, indicates the number of class.

Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class.

It’s guaranteed that at least one data is right in each test case.

Limits

T≤100

1≤N≤100

0≤a,b,c,d,e,f,g≤100

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

Sample Input

2

2

4 5 4 4 3 2 2

5 3 1 2 0 0 0

2

0 4 10 2 3 4 9

6 12 6 3 5 3 2

Sample Output

7

15

Hint

In the second test case, the data uploaded by Class 1 is wrong.

Because we can’t find a solution which satisfies the limitation.

As for Class 2, we can calculate the number of students who only enrolled in course A is 2,

the number of students who only enrolled in course B is 6, and nobody enrolled in course C,

the number of students who only enrolled in courses A and B is 1,

the number of students who only enrolled in courses B and C is 3,

the number of students who only enrolled in courses A and C is 1,

the number of students who enrolled in all courses is 2,

so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

Source

2017 Multi-University Training Contest - Team 6

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<vector>
#include<string>
#include<cstring>
using namespace std;
typedef long long LL;
const int MAXN=1e5;
const int INF=0x3f3f3f3f;
int a[10];

int judge()
{
int x1,x2,x3,x4,x5,x6,x7;
x7=a[7];
if(a[4]>=x7) x4=a[4]-x7;
else return -1;
if(a[5]>=x7) x5=a[5]-x7;
else return -1;
if(a[6]>=x7) x6=a[6]-x7;
else return -1;
if(a[1]>=x4+x6+x7) x1=a[1]-x4-x6-x7;
else return -1;
if(a[2]>=x4+x5+x7) x2=a[2]-x4-x5-x7;
else return -1;
if(a[3]>=x5+x6+x7) x3=a[3]-x5-x6-x7;
else return -1;
return x1+x2+x3+x4+x5+x6+x7;
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
int ma=-INF;
for(int i=1;i<=n;++i)
{
for(int j=1;j<=7;++j)
{
scanf("%d",&a[j]);
}
int tmp=judge();
if(tmp!=-1) ma=max(tmp,ma);
}
printf("%d\n",ma);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: