您的位置:首页 > 其它

HDU6106 Classes(思路,2017 HDU多校联赛 第6场)

2017-08-11 09:22 746 查看
题目:


Classes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 285    Accepted Submission(s): 183


Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.

Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.

Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in
course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.

However, due to statistical errors, some data are wrong and these data should be ignored.

Smart you must know how to write a program to find the maximum number of students.

 

Input

The first line of the input gives the number of test cases T; T tes
4000
t cases follow.

Each case begins with one line with one integer N, indicates the number of class.

Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 

It's guaranteed that at least one data is right in each test case.

Limits
T≤100
1≤N≤100
0≤a,b,c,d,e,f,g≤100

 

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

 

Sample Input

2
2
4 5 4 4 3 2 2
5 3 1 2 0 0 0
2
0 4 10 2 3 4 9
6 12 6 3 5 3 2

 

Sample Output

7
15

Hint
In the second test case, the data uploaded by Class 1 is wrong.
Because we can't find a solution which satisfies the limitation.
As for Class 2, we can calculate the number of students who only enrolled in course A is 2,
the number of students who only enrolled in course B is 6, and nobody enrolled in course C,
the number of students who only enrolled in courses A and B is 1,
the number of students who only enrolled in courses B and C is 3,
the number of students who only enrolled in courses A and C is 1,
the number of students who enrolled in all courses is 2,
so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

 

Source

2017 Multi-University Training Contest - Team 6

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6107 6106 6105 6104 6103 

思路:

学校搞了个培训班,让每个班把学生的报名数据汇总一下报上去,但是有些班报的可能是假的,如果是假的,这个班就不算,再把其他班里面的最大值求出来。

题目已经给出了A,B,C,AB,BC,AC,ABC的情况,那么我们很容易就想到,选ABC的人一定包括了选AC的人,那么我们就可以把AC的真实值求出来,那么就是:

AC=AC-ABC

BC=BC-ABC

AB=AB-ABC

A=A-(AB+AC+ABC)

B=B-(AB+BC+ABC)

C=C-(BC+AC+ABC)

如果这里面任意一个值出现了负数,那么就证明这个班是错误的,就放弃,然后在剩下的里面求最大值

代码:

#include <cstdio>
#include <cstring>
#include <cctype>
#include <string>
#include <set>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 100200
#define ll long long
using namespace std;
int main()
{
int t,n,a,b,c,ab,bc,ac,abc;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int ans=0;
while(n--)
{
int num=0;
scanf("%d%d%d%d%d%d%d",&a,&b,&c,&ab,&bc,&ac,&abc);
int ac0=ac-abc;
num+=ac0;
if(ac0<0)continue;
int bc0=bc-abc;
num+=bc0;
if(bc0<0)continue;
int ab0=ab-abc;
num+=ab0;
if(ab0<0)continue;
int a0=a-(ab0+ac0+abc);
num+=a0;
if(a0<0)continue;
int b0=b-(ab0+bc0+abc);
num+=b0;
if(b0<0)continue;
int c0=c-(ac0+bc0+abc);
num+=c0;
if(c0<0)continue;
num+=abc;
ans=max(num,ans);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: