您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表六:有序链表的建立

2017-08-07 15:02 246 查看
Problem Description
输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。
Input
第一行输入整数个数N;
第二行输入N个无序的整数。
Output
依次输出有序链表的结点值。
Example Input
6
33 6 22 9 44 5Example Output
5 6 9 22 33 44Hint
不得使用数组!


#include<stdio.h>
#include<stdlib.h>
struct N
{
int d;
struct N *n;
}*head,*p,*q;
int main()
{
int m,i,t;
head=(struct N*)malloc(sizeof(struct N));
head->n=NULL;
scanf("%d",&m);
for(i=0;i<m;i++)
{
p=(struct N*)malloc(sizeof(struct N));
scanf("%d",&p->d);
p->n=head->n;
head->n=p;
}
for(p=head->n;p;p=p->n)
for(q=p->n;q;q=q->n)
if(q->d<p->d)
{
t=q->d;
q->d=p->d;
p->d=t;
}
for(p=head->n;p;p=p->n)
{
if(p->n)printf("%d ",p->d);
else printf("%d",p->d);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: