您的位置:首页 > 理论基础 > 数据结构算法

SDUTACM 数据结构实验之链表六:有序链表的建立

2016-09-29 21:29 323 查看

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;

第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Example Input

6
33 6 22 9 44 5


Example Output

5 6 9 22 33 44


Hint

  
#include<stdio.h>
#include<stdlib.h>
struct hh
{
int data;
struct hh *next;
};
int main()
{
struct hh *head,*p,*t;
int n,i,x;
head=(struct hh *)malloc(sizeof(struct hh));
head->next=NULL;
t=head;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&x);
while(t->next!=NULL&&t->next->data<x)
t=t->next;
p=(struct hh *)malloc(sizeof(struct hh));
p->data=x;
p->next=t->next;
t->next=p;
t=head;
}
p=head->next;
for(i=0;i<n-1;i++)
{
printf("%d ",p->data);
p=p->next;
}
printf("%d\n",p->data);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 数据结构