您的位置:首页 > 理论基础 > 数据结构算法

SDUT 2121 数据结构实验之链表六:有序链表的建立

2015-01-22 12:57 309 查看


数据结构实验之链表六:有序链表的建立




Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^



题目描述

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。


输入

第一行输入整数个数N;

第二行输入N个无序的整数。


输出

依次输出有序链表的结点值。


示例输入

6
33 6 22 9 44 5



示例输出

5 6 9 22 33 44



提示

不得使用数组!

#include <bits/stdc++.h>

using namespace std;

struct lists
{
struct node
{
int data;
struct node *next;
}*head;

lists()
{
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
}
void add(int n)
{
struct node *p,*src;
p=(struct node *)malloc(sizeof(struct node));
p->data=n;
p->next=NULL;
src=head;
while(src->next&&(src->next->data)<n)
src=src->next;
p->next=src->next;
src->next=p;
}
void print()
{
struct node *p=head->next;
while(p)
{
if(p!=head->next)
cout<<" ";
cout<<p->data;
p=p->next;
}
cout<<endl;
}
};

int main()
{
ios::sync_with_stdio(false);
lists s;
int n,num;
cin>>n;
while(n--)
{
cin>>num;
s.add(num);
}
s.print();

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: