您的位置:首页 > 其它

CSU-ACM2017暑假集训2-二分搜索 poj-2456 Aggressive cows-最大化最小值

2017-07-25 17:03 375 查看

题目:


Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them
is as large as possible. What is the largest minimum distance?

Input
* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output
* Line 1: One integer: the largest minimum distance

Sample Input
5 3
1
2
8
4
9


Sample Output
3


Hint
OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

             题意:给你N个栅栏的坐标,你有C头牛,你想要你的的牛的距离间隔尽可能的远,问如何放牛,使得所有牛的间隔里最小的那个间隔最大

            思路:二分这个最大的最小间隔,并判断可行性。

            代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

int n,c;
int s[111111];

int judge(int dis)
{
int l=0,r=1;
int counts=0;
while(1)
{
while(r<n&&s[r]-s[l]<dis)
r++;
if(r==n&&counts!=c-1)
return 0;
l=r;
counts++;
if(counts==c)
return 1;
}
return 0;
}

int bs(int l,int r)
{
while(l<=r)
{
int m=(r-l)/2+l;
if(judge(m))
l=m+1;
else
r=m-1;
}
return  l-1;
}

int main()
{
while(scanf("%d%d",&n,&c)!=EOF)
{
for(int i=0;i<n;i++)
{
scanf("%d",&s[i]);
}
sort(s,s+n);
int ans=bs(0,s[n-1]/c);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: