您的位置:首页 > 其它

poj 2456 Aggressive cows(二分搜索之最大化最小值)

2015-09-03 17:57 453 查看
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?


Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi


Output

* Line 1: One integer: the largest minimum distance


Sample Input

5 3
1
2
8
4
9


Sample Output

3


Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.


Source

USACO 2005 February Gold

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<set>
using namespace std;
#define N 100006
#define inf 1<<32
int x
;
int n,m;
bool solve(int d){
int cnt=1;
int last=0;
for(int i=1;i<n;i++){
if(x[i]-x[last]>=d) {
cnt++;
last=i;
}
}
if(cnt>=m) return false;
return true;
}
int main()
{

while(scanf("%d%d",&n,&m)==2){
for(int i=0;i<n;i++){
scanf("%d",&x[i]);
}
sort(x,x+n);
int low=0;
int high=x[n-1]-x[0];
while(low<high){
int mid=(low+high)>>1;
if(solve(mid)){
high=mid;
}
else{
low=mid+1;
}
}
printf("%d\n",low-1);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: