您的位置:首页 > 其它

hdu1498—50 years, 50 colors(最小点覆盖)

2017-07-20 16:42 357 查看
题目链接:传送门


50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2650    Accepted Submission(s): 1509


Problem Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind
of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students
are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.



 

Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the
color of the ballon in the i row, j column.Input ends with n = k = 0.

 

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".

 

Sample Input

1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0

 

Sample Output

-1
1
2
1 2 3 4 5
-1

 

做这题前先做下hdu2119,这题会了,那本题就没问题了

hdu2119题解

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <stack>
#include <queue>
#include <set>

using namespace std;

typedef long long ll;
const int N = 10900;
const int M = 109;
const int INF = 0x3fffffff;
const double eps = 1e-8;
const double PI = acos(-1.0);

struct Edge{
int node;
Edge*next;
}m_edge
;
int girl[M];
Edge*head[M];
int Flag[M],Ecnt,cnt;

void init()
{
Ecnt = cnt = 0;
fill( girl , girl+M , 0 );
fill( head , head+M , (Edge*)0 );
}

//b对g有好感
void mkEdge( int b , int g )
{
m_edge[Ecnt].node = g;
m_edge[Ecnt].next = head[b];
head[b] = m_edge+Ecnt++;
}

bool find( int x )
{
for( Edge*p = head[x] ; p ; p = p->next ){
int s = p->node;   //有好感的女生
if( !Flag[s] ){
Flag[s] = true; //该女生在本轮匹配中被访问
if( girl[s] == 0 || find(girl[s]) ){
//女生没有对象或者另外一个男生能把这个妹纸让给x男
girl[s] = x;
return true;
}
}
}
return false;
}

int data[M][M];

//构建二分图
void Build( int n , int v )
{
init();
for( int i = 1 ; i <= n ; ++i ){
for( int j = 1 ; j <= n ; ++j ){
if( data[i][j] == v ) mkEdge(i,j);
}
}
}

void solve( int n )
{
for( int i =  1 ; i <= n ; ++i ){
fill( Flag , Flag+M , 0 );
if( find(i) ) ++cnt;
}
}

int main()
{
int n,k;
while( ~scanf("%d%d",&n,&k)&&n&&k ){
set<int>st;
for( int i = 1 ; i <= n ; ++i ){
for( int j = 1 ; j <= n ; ++j ){
scanf("%d",&data[i][j]);
st.insert(data[i][j]);
}
}
int tot = 0; int re[M];
for( set<int>::iterator it = st.begin(); it != st.end() ; ++it ){
int s = *it;
Build(n,s);
solve(n);
if( cnt <= k ) continue;
re[tot++] = s;
}
if( tot == 0 ) printf("-1\n");
else{
printf("%d",re[0]);
for( int i = 1 ; i < tot ; ++i ){
printf(" %d",re[i]);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: