您的位置:首页 > 其它

hdu 1498 50 years, 50 colors(二分图匹配--最小点覆盖)

2015-04-13 15:06 330 查看

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1812 Accepted Submission(s): 992



Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing
color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind
of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students
are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.





Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of
n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.



Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".



Sample Input
1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0




Sample Output
-1
1
2
1 2 3 4 5
-1




Author
8600
题目分析:

把x坐标和y坐标看成两个集合,然后进行二分图匹配,每个颜色的crash掉的最小次数就是最小匹配数,只需要枚举颜色,然后判断最大匹配数是否大于给定匹配数即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#define MAX 107

using namespace std;

int n,k,a;

struct Point
{
    int x,y;
    Point ( int a , int b )
        :x(a),y(b){}
};

vector<Point> color[MAX];
vector<int> ans;

struct Edge
{
    int v,next;
}e[MAX*MAX];

int head[MAX];
int cc;

void add ( int u , int v )
{
    e[cc].v = v;
    e[cc].next = head[u];
    head[u] = cc++;
}

int linker[MAX];
int used[MAX];

bool dfs ( int u )
{
    for ( int i = head[u] ; ~i ; i = e[i].next )
    {
        int v = e[i].v;
        if ( used[v] ) continue;
        used[v] = true;
        if ( linker[v] == -1 || dfs ( linker[v] ) )
        {
            linker[v] = u;
            return true;
        }
    }
    return false;
}

int hungary ( )
{
    int res = 0;
    memset ( linker , -1 , sizeof ( linker ) );
    for ( int i = 1 ;  i <= n ; i++ )
    {
        memset ( used , 0 , sizeof ( used ) );
        if ( dfs ( i ) ) res++;
    }
    return res;
}

int main ( )
{
    while ( ~scanf ( "%d%d" , &n , &k ) )
    {
        if ( n == 0 && k == 0 ) break;
        for ( int i = 1 ; i <= 50 ; i++ )
            color[i].clear();
        for ( int i = 1 ; i <= n ; i++ )
            for ( int j = 1 ; j <= n ; j++ )
            {
                scanf ( "%d" , &a );
                color[a].push_back ( Point ( i , j ) );
            }
        ans.clear();
        for ( int i = 1 ; i <= 50 ; i++ )
        {
            int len = color[i].size();
            if ( len == 0 ) continue;
            memset ( head , -1 , sizeof ( head ) );
            cc = 0;
            for ( int j = 0 ; j < len ; j++ )
                add ( color[i][j].x , color[i][j].y );
            int x = hungary ( );
            if ( x > k ) ans.push_back ( i );
        }
       // cout << "dsadsdasd" << endl;
        int len = ans.size();
        if( len == 0 ) puts ( "-1" );
        else for ( int i = 0 ; i < len ; i++ )
           if ( i!= len -1 ) printf ( "%d " , ans[i] );
           else printf ( "%d\n" , ans[i] ); 
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: