您的位置:首页 > 其它

HDU 1498 50 years, 50 colors 二分图最小点覆盖(基础题)

2015-08-08 10:16 483 查看
**

50 years, 50 colors

**

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1918 Accepted Submission(s): 1058

Problem Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it’s so nice, isn’t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named “crashing color balloons”.

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts “go!”,you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What’s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.



Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print “-1”.

Sample Input

1 1

1

2 1

1 1

1 2

2 1

1 2

2 2

5 4

1 2 3 4 5

2 3 4 5 1

3 4 5 1 2

4 5 1 2 3

5 1 2 3 4

3 3

50 50 50

50 50 50

50 50 50

0 0

Sample Output

-1

1

2

1 2 3 4 5

-1

题意:n*n的矩形中放入颜色值为[1,50]的气球,要求每一个人扎k次,每扎一次,可将同行或者同列相同颜色的气球全部扎破。求是否存在不可能全部扎破的气球,按照升序规律输出气球的颜色。

题解:对每种颜色进行最小点覆盖运算,如果最小覆盖点num>k,则该颜色气球不能全部扎破。

矩形行列分别为集合A和集合B,如果判断颜色k气球,则如果map[i][j] = k,则表示存在一条边,这样便可以转换成最小点覆盖问题,只需要找出最小的点,清除掉两集合之间所有的边即可。

[code]/*-------------最小点覆盖运算-------------------

题意:n*n的矩形中放入颜色值为[1,50]的气球,要求每一个人扎k次,每扎一次,可将同行或者同列相同颜色的气球全部扎破。求是否存在不可能全部扎破的气球,按照升序规律输出气球的颜色。

题解:对每种颜色进行最小点覆盖运算,如果最小覆盖点num>k,则该颜色气球不能全部扎破。
矩形行列分别为集合A和集合B,如果判断颜色k气球,则如果map[i][j] = k,则表示存在一条边,这样便可以转换成最小点覆盖问题,只需要找出最小的点,清除掉两集合之间所有的边即。
--------------------------------------------*/

#include <iostream>
#define re(i, n) for(int i = 0; i < n; ++ i)//简化for循环
using namespace std;

const int nMax = 105;
int map[nMax][nMax];//气球的总图
int link[nMax];//link[j]:第j列被扎过时,扎的气球位置的行(无则-1)
int useif[nMax];//第i列是否被扎过
int ans[nMax];//记录不能全部扎破的气球,ans[i]为某颜色数值
int len;
int n, k;

int dfs(int t, int col)
{
    re(i, n)
    {
        if(!useif[i] && map[t][i] == col)
        {
            useif[i] = 1;
            //寻找增广路,如果有增广路,说明该位置需要扎气球
            if(link[i] == -1 || dfs(link[i], col))
            {
                link[i] = t;//说明i列被扎过,初始扎的气球位置在t行
                return 1;
            }
        }
    }
    return 0;
}

int maxMatch(int col)
{
    memset(link, -1, sizeof(link));
    int num = 0;
    re(i, n)
    {
        memset(useif, 0, sizeof(useif));//对每一行都要初始化
        if(dfs(i, col)) num ++;
    }
    return num;
}

int main()
{
    //freopen("f://data.in", "r", stdin);
    while(scanf("%d %d", &n, &k) != EOF)
    {
        memset(map, 0, sizeof(map));
        len = 0;
        if(!n && !k) break;
        re(i, n) re(j, n) scanf("%d", &map[i][j]);
        for(int i = 1; i <= 50; ++ i)
        {
            if(maxMatch(i) > k)//每种颜色都判断一次,执行n次最小点覆盖
                ans[len ++] = i;
        }
        if(!len) 
            printf("-1\n");
        else
        {
            re(i, len - 1) printf("%d ", ans[i]);
            printf("%d\n",ans[len - 1]);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: