您的位置:首页 > 其它

【树状数组--求逆序数】poj3067 Japan

2017-07-13 23:08 309 查看
Japan

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28526 Accepted: 7707
Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast
are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of
crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the
East coast and second one is the number of the city of the West coast.
Output

For each test case write one line on the standard output: 

Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1

Sample Output
Test case 1: 5

Source
题意:东西海岸各有n,m个城市,k条线路想连;问有多少条线路是交叉的;
思路:按照 l 从小到大排序,然后求 r 的逆序数;坑点就是所有逆序数的和会超int的范围;

//不必害怕忘记,通过再一次对知识点的学习巩固,才能更好的掌握!

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;

const int N=1004;
ll C
;
struct node
{
ll l,r;
}a[1000006];
int n,m,k;

int lowbit(ll x)
{
return x&(-x);
}

ll sum(ll x)
{
ll ret=0;
while(x>0)
{
ret+=C[x];
x-=lowbit(x);
}
return ret;
}

void add(ll x,ll d)
{
while(x<=N)
{
C[x]+=d;
x+=lowbit(x);
}
}

int cmp(node x,node y)
{
if(x.l!=y.l)
return x.l<y.l;
return x.r<y.r;
}

int main()
{
int T;
scanf("%d",&T);
for(int j=1;j<=T;j++)
{
memset(a,0,sizeof(a));
memset(C,0,sizeof(C));

scanf("%d%d%d",&n,&m,&k);
for(int i=1;i<=k;i++)
scanf("%lld%lld",&a[i].l,&a[i].r);
sort(a+1,a+1+k,cmp);

ll ans=0;
for(int i=1;i<=k;i++)
{
ll x=i-1-sum(a[i].r);
ans+=x;
add(a[i].r,1);
}

printf("Test case %d: %lld\n",j,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  树状数组