您的位置:首页 > 其它

POJ 3067 Japan 【树状数组-逆序对】

2018-01-16 19:28 513 查看
Japan

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30282 Accepted: 8151
Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast
are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of
crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the
East coast and second one is the number of the city of the West coast.
Output

For each test case write one line on the standard output: 

Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1

Sample Output
Test case 1: 5

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long
const int MAX = 1e6;
int c[MAX];
struct node
{
int x, y;
} a[MAX];
bool cmp(node a, node b)
{
if(a.x == b.x)
return a.y < b.y;
return a.x < b.x;
}
int lowbit(int i)
{
return i & -i;
}
void add(int i, int num)
{
while(i < MAX)
{
c[i] += num;
i += lowbit(i);
}
}
int Sum(int i)
{
ll sum = 0;
while(i > 0)
{
sum += c[i];
i -= lowbit(i);
}
return sum;
}
int main()
{
int N;
scanf("%d", &N);
int Case = 0;
while(N--)
{
int n, m, k;
scanf("%d%d%d", &n, &m, &k);
for(int i = 0; i < k; i++)
scanf("%d%d", &a[i].x, &a[i].y);
sort(a, a + k, cmp);
memset(c, 0, sizeof c);
ll ans = 0;
for(int i = 0; i < k; i++)
{
ans += (i - Sum(a[i].y));
add(a[i].y, 1);
}
printf("Test case %d: %lld\n", ++Case, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: