您的位置:首页 > 其它

POJ 3067 Japan(树状数组求逆序对)

2013-07-27 12:48 357 查看
Japan

http://poj.org/problem?id=3067

Time Limit: 1000MS

Memory Limit: 65536K

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast
are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of
crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the
East coast and second one is the number of the city of the West coast.
Output

For each test case write one line on the standard output:

Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1

Sample Output
Test case 1: 5


题意抽象:

设二分图(偶图)G<V,E>的二部划分为(V1,V2),|V1|=N,|V2|=M,|E|=K。已知V1和V2上的点分别在两条平行线上,点与点之间径直相连且每个交点最多在两条直线上,求交点个数。

解法:
复杂度:


1. 对两点集的元素排序,优先级V1>V2
const int MAXN = 1002;

struct Node {
		int a, b;
} node[MAXN * MAXN];

bool cmp(Node a, Node b) {
	return a.a != b.a ? a.a < b.a : a.b < b.b;
}

sort(node + 1, node + 1 + K, cmp);


2. 然后逐渐添加连线,同时统计V2端比b大的点的个数。注意和值较大,要用long long。
int lowbit(int x) {
	return -x & x;
}

void add(int i, int val) {
	while (i <= M) {
		c[i] += val;
		i += lowbit(i);
	}
}

int sum(int i) {
	int s = 0;
	while (i) {
		s += c[i];
		i -= lowbit(i);
	}
	return s;
}

long long ans = 0;
add(node[1].b, 1);
for (int i = 2; i <= K; i++) {
	add(node[i].b, 1);
	ans += sum(M) - sum(node[i].b);//统计比node[i].b大的点个数,O(log M)时间
}


完整代码:

/*485ms,2760KB*/

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;

const int MAXN = 1002;
int c[MAXN];
int N, M, K;

struct Node {
		int a, b;
} node[MAXN * MAXN];

bool cmp(Node a, Node b) {
	return a.a != b.a ? a.a < b.a : a.b < b.b;
}

int lowbit(int x) {
	return -x & x;
}

void add(int i, int val) {
	while (i <= M) {
		c[i] += val;
		i += lowbit(i);
	}
}

//前i项和
int sum(int i) {
	int s = 0;
	while (i) {
		s += c[i];
		i -= lowbit(i);
	}
	return s;
}

int main() {
	int T;
	scanf("%d", &T);
	for (int iCase = 1; iCase <= T; iCase++) {
		scanf("%d%d%d", &N, &M, &K);
		for (int i = 1; i <= K; i++) {
			scanf("%d%d", &node[i].a, &node[i].b);
		}
		///////////////////////
		sort(node + 1, node + 1 + K, cmp); //排序
		memset(c, 0, sizeof(c));
		long long ans = 0;
		add(node[1].b, 1);
		for (int i = 2; i <= K; i++) {
			add(node[i].b, 1);
			ans += sum(M) - sum(node[i].b);//统计比node[i].b大的点个数,O(log M)时间
		}
		printf("Test case %d: %I64d\n", iCase, ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: