您的位置:首页 > 其它

poj 3070 Fibonacci 矩阵快速幂

2017-07-09 21:41 393 查看
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is


.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix.


.

题解:

按题目要求很容易写出矩阵

F
0 1 1


F[n-1] 0 1 0

直接上矩阵快速幂即可

#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
typedef long long ll;
const int mod=10000;
int n;
struct matrix
{
ll a[3][3];
matrix(){for(int i=1;i<=2;i++)for(int j=1;j<=2;j++)a[i][j]=0;}
matrix(ll b[3][3]){for(int i=1;i<=2;i++)for(int j=1;j<=2;j++)a[i][j]=b[i][j];}
inline matrix operator *(matrix p){
matrix tmp;
for(int i=1;i<=2;i++)
for(int j=1;j<=2;j++){
tmp.a[i][j]=0;
for(int k=1;k<=2;k++)
tmp.a[i][j]+=a[i][k]*p.a[k][j],tmp.a[i][j]%=mod;
}
return tmp;
}
};
ll work(){
if(n==0)return 0;
if(n==1||n==2)return 1;
n-=2;
ll t[3][3]={{0,0,0},{0,1,1},{0,0,0}};ll sum[3][3]={{0,0,0},{0,1,1},{0,1,0}};
matrix S=matrix(t),T=matrix(sum);
while(n){
if(n&1)S=S*T;
T=T*T;n>>=1;
}
return S.a[1][1];
}
int main()
{
while(scanf("%d",&n))
{
if(n==-1)break;
printf("%lld\n",work());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: