您的位置:首页 > 其它

POJ 3070 Fibonacci(矩阵快速幂模板)

2015-03-03 20:34 453 查看
Fibonacci

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10007Accepted: 7141
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

Source
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <stdlib.h>
#include <algorithm>
#include <cmath>
#include <map>
#define inf 0x3f3f3f3f
#define mod 10000
using namespace std;
struct node
{
    int m[2][2];
};
node Mul(node a,node b)
{
    node c;
    memset(c.m,0,sizeof(c.m));
    for(int i=0; i<2; i++)
        for(int j=0; j<2; j++)
            for(int k=0; k<2; k++)
                c.m[i][j] += (a.m[i][k]*b.m[k][j])%mod;
    return c;
}
node fastm(node a,int n)
{
    node res;
    memset(res.m,0,sizeof(res.m));
    res.m[0][0] = res.m[1][1] = 1;
    while(n)
    {
        if(n&1)
            res = Mul(res,a);
        n>>=1;
        a = Mul(a,a);
    }
    return res;
}

void MPow(node a,int n)
{
    if(n == 0)
    {
        printf("0\n");
        return ;
    }
    node res = fastm(a,n/2);
    res = Mul(res,res);
    if(n&1)
        res = Mul(res,a);
    printf("%d\n",res.m[0][1]%mod);
}
int main()
{
    int n;
    while(scanf("%d",&n) && n!=-1)
    {
        node a;
        a.m[0][0]=1;
        a.m[0][1]=1;
        a.m[1][0]=1;
        a.m[1][1]=0;
        MPow(a,n);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: