您的位置:首页 > 其它

POJ 3070-Fibonacci(矩阵快速幂求斐波那契数列)

2015-03-04 19:47 465 查看
Fibonacci
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ
3070

Appoint description:
System Crawler (2015-02-28)

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1


Sample Output

0
34
626
6875


Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

题意:题意:求第n个Fibonacci数mod(m)的结果,当n=-1时,break。其中n(where 0 ≤ n ≤ 1,000,000,000) ,m=10000;

思路:常规方法肯定超时,这道题学会了用矩阵快速幂求斐波那契。如下图:



A = F(n - 1), B = F(N - 2),这样使构造矩阵

的n次幂乘以初始矩阵

得到的结果就是



#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
using namespace std;
const int inf=0x3f3f3f3f;
const int mod=10000;
struct node
{
int mp[3][3];
}init,res;
struct node Mult(struct node x,struct node y)
{
struct node tmp;
int i,j,k;
for(i=0;i<2;i++)
for(j=0;j<2;j++)
{
tmp.mp[i][j]=0;
for(k=0;k<2;k++)
{
tmp.mp[i][j]=(tmp.mp[i][j]+x.mp[i][k]*y.mp[k][j])%mod;
}
}
return tmp;
}
struct node expo(struct node x, int k)
{
int i,j;
struct node tmp;
for(i=0;i<2;i++)
for(j=0;j<2;j++)
{
if(i==j)
tmp.mp[i][j]=1;
else
tmp.mp[i][j]=0;
}
while(k)
{
if(k&1) tmp=Mult(tmp,x);
x=Mult(x,x);
k>>=1;
}
return tmp;
}
int main()
{
int k;
while(~scanf("%d",&k))
{
if(k==-1) break;
init.mp[0][0]=1;
init.mp[0][1]=1;
init.mp[1][0]=1;
init.mp[1][1]=0;
res=expo(init,k);
printf("%d\n",res.mp[0][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: