您的位置:首页 > 大数据 > 人工智能

PAT甲级真题及训练集(23)--1079. Total Sales of Supply Chain (25)(未全部测试通过,pat24分)

2017-07-09 16:27 459 查看

1079. Total Sales of Supply Chain (25)

时间限制

250 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain
has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the
root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being
0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.
Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:
42.4


提交代码



/**
作者:一叶扁舟
时间:21:24 2017/7/8
思路:未全部测试通过,pat测试24分,还有一个case没有通过,猜测应该是临界值,比如0之类的

*/
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <stack>
#include <queue>
#include <math.h>
#include <string.h>
#include <vector>
using namespace std;
#define SIZE 100001

typedef struct TreeNode{
int data;
vector<int> child;
int depth;//深度
int weight;//权值
}TreeNode;

//定义的树,可以用结构体,也可以用直接用vector<int> tree来定义
TreeNode tree[SIZE];
int root[SIZE] = { 0 };//0默认是根节点,1是子结点

void getTreeDepth(int rootNum, int depth){
//到了叶子节点
if (tree[rootNum].child.size() == 0){
tree[rootNum].depth = depth;
return;
}

for (unsigned int i = 0; i < tree[rootNum].child.size(); i++){
//递归访问root的子结点
getTreeDepth(tree[rootNum].child[i], depth + 1);
}

}
int getRoot(int N){
for (int i = 0; i < N; i++){
if (root[i] != 1){
return i;
}
}
return 0;
}
int main(){
int N;
double  m;//价格增加的倍数
double r;//价格每次增加的比率
scanf("%d %lf %lf", &N, &m, &r);
r = r / 100;
for (int i = 0; i < N; i++){
int num;
scanf("%d",&num);
if (num == 0){//叶子节点有权值
int weight;
scanf("%d", &weight);
tree[i].weight = weight;
}
else{
for (int j = 0; j < num; j++){
int temp;

scanf("%d", &temp);
root[temp] = 1;//子结点再这里出现了,说明不可能是根节点
//存入对应的孩子结点
tree[i].child.push_back(temp);
}
}

}
//得到根结点
int rootNum = getRoot(N);
getTreeDepth(rootNum,0);
double result = 0;
//遍历整个树,计算总价格
for (int i = 0; i < N; i++){
//找到depth大于0的
if (tree[i].depth >0){
double temp = m * pow(1 + r, tree[i].depth) * tree[i].weight;
result += temp;
}
}
//输出
if (N == 0){
printf("0\n");
return 0;
}
printf("%.1f\n",result);
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息