您的位置:首页 > 其它

PAT甲级真题及训练集(8)--1006. Sign In and Sign Out (25)

2017-06-21 17:23 531 查看


1006. Sign In and Sign Out (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked
the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time


where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:
SC3021234 CS301133


提交代

/**
作者:一叶扁舟
时间:23:46 2017/6/18
思路:

*/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define SIZE 100001
typedef struct WorkTime{
char id[20];//员工的id
char startTime[10];//上班时间
char endTime[10];//下班时间
}WorkTime;
int main(){
int N;
char id[15], firstTime[10], endTime[10];
int firstNum;//上班最早的员工坐标
int endNum; //下班最晚的员工坐标
WorkTime workTime[SIZE];
char maxTime[10] = "23:59:59";
char minTime[10] = "00:00:00";
scanf("%d", &N);
for (int i = 0; i < N; i++){
scanf("%s %s %s", id, firstTime, endTime);
strcpy(workTime[i].id, id);
strcpy(workTime[i].startTime ,firstTime);
strcpy(workTime[i].endTime , endTime);
if (strcmp(firstTime, maxTime) <= 0){//比较上班时间,找到最早上班的人
strcpy(maxTime,firstTime);
firstNum = i;
}

if (strcmp(endTime, minTime) >= 0){//找到最晚下班的人
strcpy(minTime, endTime);
endNum = i;
}

}

printf("%s %s", workTime[firstNum].id, workTime[endNum].id);

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  SignInandSignOut pat