您的位置:首页 > 运维架构

HDU 2648 Shopping (map与迭代器)

2017-05-06 20:29 169 查看
very girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants to know the rank of this shop's
price after the change of everyday.

Input

One line contians a number n ( n<=10000),stands for the number of shops. 

Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop. 

Then a line contians a number m (1<=m<=50),stands for the days . 

Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s. 

Output

Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.

Sample Input

3

memory

kfc

wind

2

49 memory

49 kfc

48 wind

80 kfc

85 wind

83 memory

Sample Output

1

2

#include <iostream>
#include <map>
#include <string>
using namespace std;
map<string,int>str;
int main()
{
int n,m,me,s,ans;
string name;
while(cin>>n)
{
me=0;
str.clear();
for(int i=0;i<n;i++)
cin>>name; //此处输入并无任何实际意义
cin>>m;
while(m--)
{
for(int i=0;i<n;i++){
cin>>s>>name;
if(name=="memory")
me+=s;
else
str[name]+=s;//string的特性,元素名可以为字符串
}
ans=1;
for(map<string,int >::iterator iter=str.begin();iter!=str.end();iter++) //迭代器的使用
{
if(iter->second>me)
ans++;
}
cout << ans << endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++STL