您的位置:首页 > 运维架构

hdu 2648(Shopping) STL map的使用

2014-11-02 14:56 288 查看

Shopping

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2018 Accepted Submission(s): 666



[align=left]Problem Description[/align]

Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants
to know the rank of this shop's price after the change of everyday.

[align=left]Input[/align]

One line contians a number n ( n<=10000),stands for the number of shops.

Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.

Then a line contians a number m (1<=m<=50),stands for the days .

Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.

[align=left]Output[/align]

Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.

[align=left]Sample Input[/align]

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory


[align=left]Sample Output[/align]

1
2


本题可以用哈希表做,由于哈希表的时间为常数级的所以非常快的,由于还没深入研究哈希表,所以用STL map做的,待深入学习哈希表后再更新此题的另一种做法。题意就不详细说了,看一下都懂的。

#include<string>
#include<map>
using namespace std;
const int maxn = 10001;
string a[maxn];
int main()
{
int m,i;
while(cin>>m)
{
for(i=0; i<m; i++)
{
cin>>a[i];
}
int n;
cin>>n;
map<string,int> M; //键值对
map<string,int> :: iterator it; //iterator为一个迭代器
while(n--)
{
int price;
string shop;
for(i=0;i<m;i++)
{
cin>>price>>shop;
M[shop] += price;
}
int cnt = 0;
for(it = M.begin();it!=M.end();it++)
{
if(it->second > M["memory"]) //it->second表示第二个参数,也就是price.M["memory"]表示memory这个店铺的price.
cnt++;
}
cout<<cnt+1<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: