您的位置:首页 > 运维架构

HDU 2648 Shopping

2013-06-08 15:21 225 查看

Shopping

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1153    Accepted Submission(s): 408

[align=left]Problem Description[/align]
Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants to know the rank of this shop's
price after the change of everyday.
 

[align=left]Input[/align]
One line contians a number n ( n<=10000),stands for the number of shops.

Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.

Then a line contians a number m (1<=m<=50),stands for the days .

Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.

 

[align=left]Output[/align]
Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.
 

[align=left]Sample Input[/align]

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

 

[align=left]Sample Output[/align]

1
2

 

[align=left]Author[/align]
dandelion
 

[align=left]Source[/align]
曾是惊鸿照影来  

#include<cstdio>
#include<map>
#include<string>
using namespace std;
int n,m;
map<string, int> mp;
char s[40];
int main()
{
while(scanf("%d", &n) == 1)
{
mp.clear();
for(int i = 0; i < n;i++)
{
scanf("%s", s);
mp.insert( make_pair(string(s) , 0) );
}
scanf("%d", &m);
for(int i = 0; i < m; i++)
{
for(int j = 0; j < n; j++)
{
int x;
scanf("%d %s",&x,s);
mp[string(s)] += x;    //注意理解题意,题目的意思是累加的
}
int cnt = 0,p = mp[string("memory")];
for(map<string,int>::iterator i = mp.begin(); i != mp.end(); i++)
if(i -> second > p) cnt++;

printf("%d\n",cnt+1);
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: