您的位置:首页 > 其它

HDU 1548 A strange lift (简单bfs)

2017-04-18 22:36 351 查看

A strange lift

[align=left]Problem Description[/align]
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will
go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there
is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2
th floor,as you know ,the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

 

[align=left]Input[/align]
The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.
 

[align=left]Output[/align]
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

[align=left]Sample Input[/align]

5 1 5
3 3 1 2 5
0

 

[align=left]Sample Output[/align]

3

分析:简单bfs

AC代码:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=200+10;
int N,A,B;
int d[maxn];
int a[maxn];

void bfs(){
memset(d,-1,sizeof(d));
queue<int>q;
q.push(A);
d[A]=0;
while(!q.empty()){
int u=q.front();
q.pop();

if(u==B){
printf("%d\n",d[B]);
return ;
}

for(int i=0;i<2;i++){
int v;
if(i==0) //下
v=u-a[u];
else v=u+a[u]; //上

if(v>N || v<1 || d[v]!=-1)continue;
q.push(v);
d[v]=d[u]+1;
}
}
printf("-1\n");
}
int main(){
while(scanf("%d",&N)==1 && N){
scanf("%d%d",&A,&B);
for(int i=1;i<=N;i++)
scanf("%d",&a[i]);
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: