您的位置:首页 > 其它

已知二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列

2017-02-19 18:36 591 查看
题目描述
输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。
输入
第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。
输出
输出该二叉树的后序遍历序列。
示例输入
ABDCEF
BDAECF
示例输出
DBEFCA

关键是要找到左子树先序遍历和中序遍历所分别对应的下标,和他们的长度表达式。

#include <iostream>
#include <cstring>
#define MAX 50+3
using namespace std;
typedef char Elem_Type;
typedef struct BiTree
{
Elem_Type data;//数据
struct BiTree *Lchild;//左孩子
struct BiTree *Rchild;//右孩子
}BiTree;      //要查找的元素  查找的地方    数组的长度
int Search_Num(Elem_Type num,Elem_Type *array,int len)
{
for(int i=0; i<len; i++)
if(array[i] == num)
return i;
//return -1;//没有找到
}                     //前序遍历         中序遍历   中序数组长度
BiTree *Resume_BiTree(Elem_Type *front,Elem_Type *center,int len)
{
if(len <= 0)
return NULL;
BiTree *temp = new BiTree;
temp->data = *front;
int index = Search_Num(*front,center,len);
temp->Lchild = Resume_BiTree(front+1,center,index);      //关键
temp->Rchild = Resume_BiTree(front+index+1,center+index+1,len-index-1);   //关键
return temp;
}
void PostOrderTraverse(BiTree *root)//后序遍历
{
if( root != NULL)
{
PostOrderTraverse(root->Lchild);
PostOrderTraverse(root->Rchild);
cout<<root->data;
}
}
int main(void)
{
Elem_Type *preorder = new Elem_Type [MAX];//前序
Elem_Type *inorder  = new Elem_Type [MAX];//中序
cin>>preorder;cin>>inorder;
BiTree *root = Resume_BiTree(preorder,inorder,strlen(inorder));
PostOrderTraverse(root);
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐