您的位置:首页 > 其它

POJ3176-Cow Bowling-简单dp

2017-02-16 21:35 323 查看
原题链接

Cow Bowling

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 18427 Accepted: 12264

Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

7

3   8

8   1   0

2   7   4   4


4 5 2 6 5

Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

7

*

3   8

*

8   1   0

*

2   7   4   4

*


4 5 2 6 5

The highest score is achievable by traversing the cows as shown above.

Source

USACO 2005 December Bronze

#include <cstdio>
#include <iostream>
using namespace std;
int n,dp[2][360],a[360];
int main(){
cin >> n;
for(int cen=1;cen<=n;cen++){
for(int i=0;i<cen;i++) scanf("%d",&a[i]);
dp[cen&1][0]=dp[(cen-1)&1][0] + a[0];
for(int i=1;i<cen;i++)
dp[cen&1][i] = max(dp[(cen-1)&1][i-1] + a[i],dp[(cen-1)&1][i] + a[i]);
}
int res=dp[n&1][0];
for(int i=1;i<n;i++) res = max(res,dp[n&1][i]);
cout << res << endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: