您的位置:首页 > 其它

poj3176——Cow Bowling(dp)

2016-04-21 18:33 344 查看
Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

7

3   8

8   1   0

2   7   4   4


4 5 2 6 5

Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

就是那个数塔

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#define MAXN 1005
using namespace std;
int dp[400][400],a[400][400];
int main()
{
int n,i,j;
while(~scanf("%d",&n))
{
for(i=1;i<=n;++i)
for(j=1;j<=i;++j)
scanf("%d",&a[i][j]);
for(i=1;i<=n;++i)
dp
[i]=a
[i];
for(i=n-1;i>=1;--i)
for(j=1;j<=i;++j)
{
dp[i][j]=max(dp[i+1][j]+a[i][j],dp[i+1][j+1]+a[i][j]);
}
printf("%d\n",dp[1][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: