您的位置:首页 > 其它

【POJ】1611--The Suspects (并查集)

2017-02-11 22:25 344 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 35844 Accepted: 17415
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source
Asia Kaohsiung 2003
4000

思路:
一个组织里,只要有一个人有生病的嫌疑,其他人都由嫌疑。现在已知编号为0的同学有嫌疑,
那么要知道有几个人有嫌疑,就需要知道和0在一个团队里的共有多少人,即和0同一个根的人数。

#include<stdio.h>
int f[30000+11];
int pre[30000+11];
int find(int x)
{
int r=x;
while(r!=f[r])
r=f[r];
int i=x,j;
while(i!=r) //路径压缩
{
j=f[i];
f[i]=r;
i=j;
}
return r;
}
int join(int x,int y)
{
int fx,fy;
fx=find(x);
fy=find(y);
if(fx!=fy)
f[fy]=fx;
}
int main()
{
int m,n,i,j,num,k;
while(scanf("%d%d",&n,&m)&&(n||m))
{
num=1;
for(i=0;i<n;i++)
f[i]=i;
for(i=0;i<m;i++)
{
scanf("%d",&k);
for(j=0;j<k;j++)
{
scanf("%d",&pre[j]);
if(j>0)
join(pre[j],pre[j-1]);
}
}
for(i=1;i<n;i++)
{
if(find(i)==find(0))
num++;
}
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: