您的位置:首页 > 其它

POJ-1611 The Suspects(并查集)

2018-03-04 11:06 423 查看
The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 45803 Accepted: 21941
DescriptionSevere acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.InputThe input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.OutputFor each case, output the number of suspects in one line.Sample Input100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0Sample Output4
1
1Code#include <cstdio>
#include <cstring>
#define N 30000

using namespace std;

int pre
;

void Init(int n)
{
for(int i=0; i<n; i++)
{
pre[i] = i;
}
}

int find(int x)
{
if(pre[x] == x)
return pre[x];
return pre[x] = find(pre[x]);
}

void join(int a, int b)
{
a = find(a);
b = find(b);
if(a != b)
{
pre[b] = a;
}
}

int main()
{
int n,m,k,boss,p;
while(~scanf("%d %d",&n,&m) && (n || m))
{
Init(n);
int sum = 0;
while(m--)
{
scanf("%d %d",&k,&boss);
for(int i=0; i<k-1; ++i)
{
scanf("%d",&p);
join(boss,p);
}
}
for(int i=0; i<n; ++i)
{
if(find(i) == pre[0]) ///0号学生是感染者
{
sum++;
}
}
printf("%d\n",sum);
}
return 0;
}
反思:题目大意:为了防止SARS扩散,学校决定隔离疑似感染者。一个学生可能参加多个社团,当一个社团中有一个疑似感染者时,全社团人员都要被隔离。每个学生都有一个唯一的编号,已知0号学生是感染者,现在要找出所有疑似感染者的数量。n为学生数量,m为社团数量,接下来m行第一个数k为该社团的人数,之后为该社团的学生编号,多组输入,当n和m同时为0时结束输入。并查集问题,判断条件为学生的祖先结点和0号学生的相同。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: