您的位置:首页 > 其它

POJ 1611 The Suspects (并查集)

2014-03-05 16:38 477 查看
链接:http://poj.org/problem?id=1611

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 20031 Accepted: 9730
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


The Submitted Code:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#define MAXN 30005
using namespace std;

int father[MAXN], N[MAXN];

void Make_Set(int n)
{
for(int i=0; i<n; i++) {
father[i] = i; //使用本身做根;每一个成员开始的父亲节点都为自身;
N[i] = 1;
}
}

int Find_Set(int x)
{
if(x != father[x]) { //合并后树的根是不变的;
father[x] = Find_Set(father[x]);
}
return father[x];
}

void Union_Set(int x, int y)
{
x = Find_Set (x);
y = Find_Set (y);
if(x == y) return ;
if(N[x] > N[y]) {
father[y] = x;
N[x] += N[y];
} else {
father[x] = y;
N[y] += N[x];
}
}

int main()
{
int n, m;

while(~scanf("%d %d", &n, &m) && n || m) {
Make_Set(n);

for(int i=0; i<m; i++) {
int Md, first, ME;
scanf("%d %d", &Md, &first);

for(int j=1; j<Md; j++) {
scanf("%d", &ME);
Union_Set(first, ME); //对属于同一个小组的成员集合进行合并;
}
}
printf("%d\n", N[Find_Set(0)]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  合并