您的位置:首页 > 其它

PAT A1069. The Black Hole of Numbers (20)

2017-01-21 10:39 405 查看
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner
we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089

9810 - 0189 = 9621

9621 - 1269 = 8352

8532 - 2358 = 6174

7641 - 1467 = 6174

... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.
Sample Input 1:
6767

Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:
2222

Sample Output 2:

2222 - 2222 = 0000

输出形式是从来没有接触过的#include <cstdio>
#include <stdlib.h>
#include <algorithm>
#include <vector>
#include <cstring>
#define MAX 1001
using namespace std;

bool cmp(int a,int b)
{
return a>b;

}

void breakn(int m,int m1[5])
{
for(int i=3;i>=0;i--)
{
m1[i]=m%10;
m/=10;
}
}
int tog
8c4a
ethern(int m1[5])
{
int m=0;
for(int i=0;i<4;i++)
{
m=m*10+m1[i];
}
return m;
}

int main()
{
int n,n0[5],n1,n2;
scanf("%d",&n);
while(1)
{
breakn(n,n0);
sort(n0,n0+4,cmp);
n1=togethern(n0);
sort(n0,n0+4);
n2=togethern(n0);
n=n1-n2;
printf("%04d - %04d = %04d\n",n1,n2,n);
if(n==0||n==6174)
break;
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: